C2C Singapore - Hong Kong Cable Offline
Incident Report for Streamline-Servers
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 01:24 UTC
Investigating
We have observed an outage on the C2C submarine cable system between Singapore and Hong Kong.
Traffic has automatically redirected via alternative paths. Customers may experience higher latency during this time.

Our team are continuing to work on a fix for this issue.
Posted Nov 14, 2023 - 09:53 UTC
This incident affected: Game & Voice Servers (Asia - Hong Kong).