Germany Maintenance
Incident Report for Streamline-Servers
Resolved
This incident has been resolved.
Posted Mar 11, 2023 - 05:47 UTC
Monitoring
Our team has now completed the maintenance and is continuing to monitor all services.

If you experience any issues, please contact our support team.
Posted Mar 10, 2023 - 08:18 UTC
Identified
Due to unforeseen circumstances, this maintenance has been extended.
Posted Mar 10, 2023 - 07:24 UTC
This incident affected: Game & Voice Servers (Europe - Germany).