Fast Download Server Maintenance

Incident Report for Streamline-Servers

Resolved

We have completed as much of the maintenance for now, returning again another date,
Posted Mar 15, 2025 - 11:40 UTC

Update

This maintenance period has been extended until the 8th March, due to unforeseen issues.
During this time there may still be short periods out connectivity issues with the Fast Download CDN.
Posted Mar 06, 2025 - 12:36 UTC

Investigating

From the 4th March to the 6th March, we will be conducting maintenance on our Fast Download CDN.
During this time, there will be moments where Fast Download will be unresponsive.
These will be short downtime moments during the scheduled time.

We apologize for any inconvenience this may cause.

Any question, please contact our support team.
Posted Mar 03, 2025 - 04:50 UTC
This incident affected: Websites (Game Panel).