New York - Hardware Upgrades
Incident Report for Streamline-Servers
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 05:14 UTC
Identified
On the 11th February our team will be doing some backbone hardware upgrades to our New York location.
From 12am until 8am (local time), there will be an increase in latency for all New York connections as well as a possible outage of roughly 30 minutes during this time.

We apologize for the inconvenience and will post updates here as they come.
Posted Feb 11, 2024 - 02:11 UTC
This incident affected: Game & Voice Servers (North America - New York) and Dedicated Servers (North America - New York).