New York HPGS Plus 1 Offline Sunday 5th January 2020 10:00:00


We have identified a drive failure in a game server machine.

System Affected: New York HPGS Plus 1

A technician has been dispatched to investigate. We apologise for any inconvenience caused.

Update 2:

We have been monitoring the machine for the last 24 hours and haven't seen any further problems.

Please reach out to our support team if you continue to experience issues.

Update 2

After the replacement of the drive, the system is continuing to experience issues.

We have placed it into a safe mode while technicians investigate.

Further updates will be provided as they become available.

Datacenter technicians have found the cause of the issue.

The game server machine is now back online and functioning.

Don't hesitate to contact our support team if any issues arise.