Singapore Upstream Issue Friday 1st November 2019 11:45:00


We have been alerted to an issue affecting one of our transit upstreams in Singapore.

Our network engineers are working with them directly

We will provide updates via our status page as they are available.

Update 3:

The upstream has resolved the issue with one of their switching stacks.

Please reach out to our support team if you are still experiences any issues connecting to Singapore services.

Update 2

Our network engineers have placed in a temporary fix while the upstream works to resolve the issue.

Please contact our support team if you continue to experience issues.

Update 1

We have received correspondence from the upstream.

They are aware of a problem with one of their core switching stacks and are working to resolve it now