Melbourne Network Outage Sunday 30th May 2021 04:05:35


Our network team has identified an outage on some services in Melbourne.

We are investigating and will provide updates as they become available.

Update 2: 5:20AM AEST

Our team has been monitoring the device affected, no further issues have been reported.

Please reach out to our support team if you have any questions or concerns.

Update 1: 4:30AM AEST

Services have now restored, our network team is investigating the root cause of the flap.