New York Game & Voice Emergency Maintenance Thursday 31st December 2020 10:30:00


Scheduled Start: 5:30 PM New York Local Time - 30/12/2020

Scheduled End: 9:30 PM New York Local Time - 30/12/2020

During the time specified, our New York game and voice services will experience a period of loss of up to 60 - 120 minutes.

Why are we performing this?

To provide security updates and general enhancements to the machines

IPs & Systems Affected

New York

Update 1:

This maintenance period has started. Further updates will be provided as they become available.

Update 2:

There have been some delays, our team are working on getting equipment online.

Update 3:

Services are now online and functioning. Please reach out to our support team if you have any issues.