Billing System Upgrades Friday 30th October 2020 16:30:00


Our team is performing upgrades to the billing system.

There will be a short period (up to 30 minutes), where customers are unable to access billing and support systems.

Updates will be provided throughout this maintenance.

Update

These systems have been upgraded.

Please reach out if you have any questions or concerns.